View Single Post
Old 10-16-2016, 02:34 PM   #725
tshering
Wizard
tshering ought to be getting tired of karma fortunes by now.tshering ought to be getting tired of karma fortunes by now.tshering ought to be getting tired of karma fortunes by now.tshering ought to be getting tired of karma fortunes by now.tshering ought to be getting tired of karma fortunes by now.tshering ought to be getting tired of karma fortunes by now.tshering ought to be getting tired of karma fortunes by now.tshering ought to be getting tired of karma fortunes by now.tshering ought to be getting tired of karma fortunes by now.tshering ought to be getting tired of karma fortunes by now.tshering ought to be getting tired of karma fortunes by now.
 
Posts: 3,481
Karma: 2914715
Join Date: Jun 2012
Device: kobo touch
Quote:
Originally Posted by MicaOlaAdams View Post
I can access the internet per wifi with KSM8s Wifi-Menu. If I don't enable wifi in KSM8 CoolReaders OPDS search gives me a network/wifi error. With wifi turned on in KSM8 I get no such error. That's why assumed Coolreader can actually connect with my router and calibre.
I guess the most recent version of PBChess was published long before the Kobo Ara One was available, and therefore does not know the path to the modules necessary to use wifi. You can try to make the following changes to vlasovsoft/wifi_on.sh:

Delete or comment out
Code:
PLATFORM=ntx508
Replace
Code:
lsmod | grep -q dhd || insmod /drivers/$PLATFORM/wifi/dhd.ko
with
Code:
lsmod | grep -q ${WIFI_MODULE} || insmod /drivers/${PLATFORM}/wifi/${WIFI_MODULE}.ko
In wifi_off.sh replace
Code:
/sbin/rmmod -r dhd
with
Code:
/sbin/rmmod -r ${WIFI_MODULE}
Note: use a unix style editor!

Last edited by tshering; 10-16-2016 at 02:41 PM.
tshering is offline   Reply With Quote