View Single Post
Old 12-30-2013, 11:26 PM   #1277
Junior Member
Evthymios began at the beginning.
Posts: 9
Karma: 10
Join Date: Dec 2013
Device: Nook Simple Touch with GlowLight, Kindle Paperwhite v1
I have a Kindle Paperwhite v1 (FW 5.3.9 - not jailbreaked). After a longer stay in a drawer (several months), its battery got depleted. A few days ago, as I tried starting it again, it stucked at the screensaver. I kept it charging for 20 hours or so, until the led turned green. It is still stuck at screensaver.

The device appears otherwise to function normally - I can connect it to PC via USB, and access the storage memory. I tried resetting it to factory defaults using file (following this post), but after getting the language selection screen - where I can select "English (United Stated)" - the device continues booting and stucks at the same screensaver. I managed to reapply the latest FW, the update seemed to go normally, but at the end it is still in the screensaver mode.

Is there anything else I can try, considering it isn't jailbreaked - anything besides serial port approach?
Evthymios is offline   Reply With Quote