View Single Post
Old 11-24-2013, 11:54 AM   #697
Junior Member
micmic began at the beginning.
Posts: 3
Karma: 10
Join Date: Nov 2013
Device: kindle, marvin, moon+
Search issue with Moon+, no connection with Marvin

Hi vlad,

first of all: great job!

COPS is exactly what I was looking for when I got my synology a and tried to download ebooks to my reade without my calibre (and my computer) running all the time.

Well, I am still struggling a bit with the configuration, any advice is appreciated.
I installed my calibre files following the description in the FAQ:
My data files are stored outsided webroot.

First question: the FAQ states to set calibre_internal_directory:

$config['calibre_internal_directory'] = '/volume1/logiciel/feedbook/';
Some postings ago I saw the hint that this variable should only be used for nginx. The default web server for synology is apache. Is the FAQ outdated or am I missing something?

Second question: Moon+ reader is my preferred reader. Unfortunately I am not able to get the search function running for this reader.
This is my config_local.php:

    if (!isset($config))
        $config = array();
     * The directory containing calibre's metadata.db file, with sub-directories
     * containing all the formats.
     * BEWARE : it has to end with a /
    $config['calibre_directory'] = '/volume1/calibre/data/';
    $config['calibre_internal_directory'] = '/volume1/calibre/data/';
    $config['cops_x_accel_redirect'] = "X-Sendfile";
     * Catalog's title
    $config['cops_title_default'] = "Syno-1";
     * use URL rewriting for downloading of ebook in HTML catalog
     * See README for more information
     *  1 : enable
     *  0 : disable
    $config['cops_use_url_rewriting'] = "1";
    $config['cops_generate_invalid_opds_stream'] = "1";
From previous posts I tried cops_generate_invalid_opds_stream = 0.

- That didn't help for Moon+ Reader, but disabled the search button in Alkido.
Does this mean: searching either in Moon+ or in Alkido, but not in both?

- what needs to done to enable searching for Moon+? For testing, I also configured your demo server in Moon+: I was surprised to get no search button there also. Any suggestions?

Third question: For my Ipad, I tried to access my ebooks with marvin:
I use this as feed: This works in my ipad's browser, but Marvin complains "this feed is invalid". I also tried without My apache error file contains not entries indicating access issues. Does Marvin require any special configuration? Anyone accessing COPS using Marvin?

micmic is offline   Reply With Quote