View Single Post
Old 06-11-2013, 08:33 PM   #28
Junior Member
InjuredSongfest began at the beginning.
Posts: 1
Karma: 10
Join Date: Jun 2013
Device: Kindle Fire (1st Gen, rooted)
Since this thread is still the first result listed on a Google search for "Kindle Fire battery fix", I'm going to assume there are still folks out there who are experiencing similar problems and looking for a solution, especially those who own a first generation KF which has fallen out of the warranty period.

After MANY attempts to fix the issue using the steps provided by the OP, I eventually gave up. Months later, I returned to my no-longer-under-warranty KF with an idea to approach the problem from a different angle; I would attempt physically open up the device and see what I could find.

Right away, I could see the battery's connector cable had loosened on one end. I re-seated the connector, snapped the cover back on, plugged it in, and left it to sit.

VOILA! The problem was solved... or so it seemed. It worked flawlessly until the next day when that little question mark over the battery indicator returned and the device shut off as soon as the charging cable was removed.

I immediately opened it back up and found that the battery itself had slipped away from the motherboard, disconnecting itself. Two minutes, a pair of scissors, and some foam-rubber sticky-grips later, it was FINALLY FIXED (hopefully for good this time).

I would not recommend anyone attempt this while their KF is under warranty, but otherwise there are plenty of great guides out there on how to remove the rear cover. Make sure you know what you're doing, then have at it!

Hope this helps
InjuredSongfest is offline   Reply With Quote