View Single Post
Old 05-26-2013, 12:09 PM   #98
Br*ste1 began at the beginning.
Posts: 24
Karma: 10
Join Date: Jul 2012
Device: PRS-T1
After waiting for over a week for replies, I finally tackled this myself, via:

sudo dd bs=512 if=/dev/sdb of=/mybackup/PRST1.img conv=noerror,notrunc,sync

I got only 7 errors, so a total of 3.5kb was uncopyable, but in the end I got my 2GB image file. After erasing the partition table, I tried to restore the image I made, but that failed at 482MB, this time, any of the options (sync,notrunc,noerror) didn't help.

And so I was screwed - or so I thought.

One interesting thing to note is that restoring ended at:
941745+0 records in
941744+0 records out
...with the counter being 1 record off.

Anyway, to my surprise I saw that, despite of 75% of the restore failing (?), in Gparted all the partitions were there again. So I downloaded partitions sdb 1,2,5,6,7 from entodoays' post and restored those without issues (using dd).

Then, just to see what happens, I ran:

sudo dd if=/dev/sdb of=/mybackup/PRST1.img

...and to my utter surprise, it went through completely without errors.

Unplugged everything, restarted the reader, uploaded a couple of books, and the device still works. I can even read books!

I really have no clue why the device isn't actually bricked now, let alone if the original issues are fixed. Just posting these tidbits since they may be helpful to others.
Br*ste1 is offline   Reply With Quote