View Single Post
Old 04-26-2013, 06:14 PM   #229
Junior Member
happy_123 began at the beginning.
Posts: 8
Karma: 10
Join Date: Jan 2013
Device: Kindle Paperwhite
Originally Posted by mjwilson View Post
Hopefully this newer version is better.

I tried using the new version for Game of Thrones and it was unsuccessful. When the file is getting generated, it searches for rawml file.

Here is the error message

calibre, version 0.9.25 (win32, isfrozen: True)
Failed to generate XRay: Failed: Generating XRay for A Clash of Kings (112)

Generating XRay for A Clash of Kings (112)
Loading Shelfari...Loading Wikipedia...Parsing book...
XRAY generation failed...
Traceback (most recent call last):
File "calibre_plugins.xray_generator.xrayaction", line 208, in run
File "calibre_plugins.xray_generator.xrayaction", line 250, in _generate_xray
File "calibre_plugins.xray_generator.xrayaction", line 500, in rawml
IOError: [Errno 2] No such file or directory: 'C:\\Users\\XX\\Documents\\Calibre Library\\George R. R. Martin\\A Clash of Kings (112)\\mobi7\\4pgsqncaltmpfmt.rawml'

The parser looks into mobi7 folder but the *.rawml is in mobi8 directory. Can you please tweak the code? Also tried for Fellowship of the ring, x-ray file is generated successfully. However there aren't vertical black bars against each characters showing their frequency of appearance in the book.
happy_123 is offline   Reply With Quote