View Single Post
Old 09-07-2008, 01:39 PM   #1
Junior Member
abbrown began at the beginning.
Posts: 6
Karma: 10
Join Date: Sep 2008
Device: PRS-505
505 corrupted - can't talk to Library - help!

I've got a bizarre problem with my PRS-505. A while ago it stopped communicating with the Sony eBook Library over USB -- it will reliably lock up the Library software when I connect it. It hangs up before the Reader even shows up on left-hand navigator, even though the Reader's 3 "drives" show up fine in Windows. At first I didn't worry about this because I could use an SD card to transfer content, but it got annoying so I recently tried to fix it.

Thinking it was some corruption on my PC (WinXP), I tried installing eBook Reader on a different computer, but the same thing happened. I then fully reset the 505 -- formatted internal memory and did a hard reset. Still didn't work. A friend just got a brand new computer so I reformatted/hard reset again and installed eBook Library on his PC and tried to hook it up - still causes eBook Library to hang hard before the device even shows up.

I called Sony and went through the diagnostic drill, and they said it was a hardware problem. So I sent my 505 away and got back a new one (this one had the new firmware on it). Plugged it in to my PC (the one where it used to cause eBook Lib to lock up) -- it showed up in eBook Library once but locked hard the instant I tried to do anything with it. It's now behaving exactly like the old one...won't even show up in eBook Library, even on a new, clean PC with a fresh install of eBook Library.

I'm at a loss of what to do next. I've tried everything I've found here -- fully uninstalling eBook Reader (including the hidden files), uninstalling the drivers, removing all traces of everything with "prs-505" and "sony" from the registry, even re-flashed the firmware on the new 505, all with no luck. I suppose I can send it back to Sony again, but how can I be sure this won't just happen again? I guess there must be something on my main PC that "infects" the reader and resets/reflashes don't clear it.

My biggest frustration is that I can't even read any of the books I've bought from the eBook store, even though I have them on SD card, because the hard reset wiped out the authorization on the Reader.

Does anyone have any ideas what else I can try? Or any way to restore the DRM authorization without eBook Library?

(And for the techies, I tried one other thing...ran a Windows Process Monitor trace on eBook Library, and it seems to lock up while doing IOCTLs on the device...I'm guessing there's some corrupt state there, which is why the USB drive aspect works but eBook Lib doesn't)

Any help much appreciated...thanks!
abbrown is offline   Reply With Quote