View Single Post
Old 04-11-2013, 01:18 AM   #1
HFC3 began at the beginning.
Posts: 30
Karma: 10
Join Date: Apr 2013
Device: Kindle Touch
Conversion successful, but "Cannot Open" on device

I know I've used Conversion before (PDF to Mobi, and I think MOBI to MOBI (to remove bad formatting and extraneous spacing)) without a problem. That was at least 2 versions of Calibre ago (before 0.9.25), though.

This time, though, when I converted a book in v0.9.25, I got a "Cannot Open. If you purchased this from Amazon, delete this book and re-download" error when I tried to open the converted book on the Kindle. I downloaded v0.9.26, and get the same results. In both cases, the converted book opened without a problem on the PC.

I've tried converting to several formats (MOBI to AZW, MOBI to MOBI, MOBI to PDF, PDF to MOBI, PDF to AZW), with the same results. I've also tried with varying conversion options (Remove blank lines, Font rescaling, as well as well as "default"), and still get a good PC conversion, but unable to open on device.

I've also reviewed the conversion debug information, and everything in there looks fine. That would make sense since the newly converted book opens on the PC.

Has anyone got any suggestions on
a) What I can do to debug why the converted books will not open on the K Touch, and/or
b) What I may be doing wrong in the conversion process?

Thank you!

HFC3 is offline   Reply With Quote