View Single Post
Old 02-15-2013, 11:04 PM   #1
Junior Member
Banjo , Klaatu Barada Niktu!Banjo , Klaatu Barada Niktu!Banjo , Klaatu Barada Niktu!Banjo , Klaatu Barada Niktu!Banjo , Klaatu Barada Niktu!Banjo , Klaatu Barada Niktu!Banjo , Klaatu Barada Niktu!Banjo , Klaatu Barada Niktu!Banjo , Klaatu Barada Niktu!Banjo , Klaatu Barada Niktu!Banjo , Klaatu Barada Niktu!
Banjo's Avatar
Posts: 9
Karma: 5276
Join Date: Feb 2013
Device: Nook Simple Touch
New Nook Simple Touch will not connect to B&N


I just registered on this forum so this is my first post. My new Nook ST will not connect to B&N so that I can register it. I have searched the forum and did not see any threads describing my problem. Sorry if I have duplicated a post.

Today I bought a Nook Simple Touch and attempted to register it. I bought it new from the MIT COOP. It is not a second hand unit. It has not been dropped or damaged.

While registering, I got through the first steps and to the WiFi screen where there was a strong signal to my wifi router. I entered the WEP key, clicked on "Connect" and the message under the SID cycled through:

"Obtaining address..."

twice and then settled down with the message

"Remembered, secured with WEP".

At that point, the "Continue with Setup" button was grayed out and did nothing. I am stuck there. Nothing I do will unstick the button.

Here is what I have tried to get this to work.

I told it to "Forget" the WEP and re-entered it. No go.
I entered the WEP in both upper case & lower case. No go.
I turned the device completely off and back on. No go.
I reconnected multiple times. No go.
I unplugged the Nook from the charger and moved it farther from the Wifi ( in case of signal overload). No go.
I had somebody else re-accomplish the entire setup. No go.

I called B&N tech support. All they could do was to read me the same instructions that had not worked. They were totally useless. They told me to call my ISP and have the Nook MAC address entered into the router. I told her that MAC filtering is turned off. I got the repeated instructions to call the ISP to have the Nook enabled in the router. After 15 minutes of that loop I gave up and hung up. Totally useless.

As instructed on the Nook, I went to and found the FAQ for the Nook ST. The online support instructions told me to go to Settings and then Wireless to toggle the Wifi off and on. The 'n' button does nothing, so there is no menu at the bottom to go to Settings. Does that only work after the Nook has been registered? What am I missing?

I logged into the router to confirm that MAC filtering is off. It is OFF. We have three computers and one smart phone currently talking to the same router through the Wifi using the same SID and WEP key without entering any MAC addresses. I could see that the Nook was connected with its own IP address and the correct MAC address that was reported from the device. So the Wifi connection is there, but the "Continue with Setup" button is still grayed out.

I pinged the Nook from the router, and the router said that it was successful, so there is a Wifi connection to the router.

So we are connected to the Wifi router, but apparently there is no internet connection or something. All the other devices on my network are working just fine. There are no error messages.

Am I doing something that is obviously wrong, or did I buy a brick?

Sorry for the long posting, but I thought that I would post all the things I have already tried to see if I left out any tricks. This is really frustrating.

My next step is to take the Nook to an open Wifi to see if it is our system ( I doubt it).

After that, I will take the Nook back to the MIT COOP, turn it in and try to find a Kobo.

Thanks in advance for any help with this.
Banjo is offline   Reply With Quote