View Single Post
Old 08-23-2008, 11:55 AM   #75
taltman711 began at the beginning.
Posts: 12
Karma: 10
Join Date: Mar 2008
Device: Kindle
Originally Posted by nohmi2 View Post
I do have my PC's registration number which I tried to use to convert .prc
and Command Prompt said that the command was not recognized. I also tried to use the number from my iPaq, which is the device that I bought the books for, again not recognized. I have three devices in Mobipocket: PC, iPaq and Kindle. The "*" is stripped from the Kindle.
I have Python 2.5.2 in my Programs(have looked in Add/Delete).
Went in Command Prompt typed in: c:\python....does not recognize it.
Have been having some help from a very kind person on Mobileread, but my computer has a curse put on it. Just about ready to throw in the towel(not really).
Sorry, I don't understand what you are saying. Are you saying that it is the mobidedrm command that is not recognized, or the PID that is not recognized. I also do not understand your reference to the "computer registration number" Do you mean the PID for that computer? A computer registration number has no use in the function you are attempting. It would be helpful if you were extremely detailed and precise in your explanations.

If it is the mobidedrm that is not recognized, then your folder structure is not correct, or your command line usage is incorrect. As TallMomof2 said, double check your folder names and use proper commands at the command prompt. After you are in the correct directory, the command prompt will look like this: C:\python(or python25). You should be able to then type in mobidedrm, hit enter, and a list of options and the usage will come up. If not, then you are doing something wrong.

If your PID is being rejected, then either the book was downloaded using none of your PIDs, your PIDs are mistyped, or the file is corrupted. Does the book open in MobiReader? If so, then it not corrupted and the PID is correct. It is your command line usage that is incorrect. If not, then the PID for your computer is incorrect at the bookstore, or the file is corrupted. Either way, delete your Kindle PID in the bookstore and re-enter your computer PID. Redownload the book. Run mobidedrm using the computer PID on the newly downloaded book. If you have gotten the command line sorted out, it should run fine. It should look like this:
c:\python25 mobidedrm book.prc PID


Last edited by taltman711; 08-23-2008 at 12:09 PM.
taltman711 is offline