View Single Post
Old 08-20-2008, 12:47 PM   #11
skoobwoman began at the beginning.
Posts: 41
Karma: 26
Join Date: Aug 2008
Location: New York, NY
Device: Kindle 2/Kindle DX/Astak Reader Pocket Pro/iPod Touch
Problem opening PDF files

I just wanted to say thanks. I was having the same problem with PDF files from another source. Downloading PDF995 driver worked like a charm with the 3 files I used it on. I'll discover other problem files as I open things on the iliad. Glad to know I can fix it now.

Originally Posted by arunava77 View Post
Issue solved - thanks for all your suggestions. I tried out all of them and have had success with Melaulur's solution. However, I modified it slightly by installing PDF995 driver
Here is everything I tried -
0. Download pdf995 driver from and install it - its free. Now load up the pdf from google books on Adobe acrobat and print it using the pdf995 pdf printer. The big advantage is that the file size is almost half the original file size. Worked perfectly for me. Many thanks to all of you and esp. Melaulur

1. pdftk - does not really do any meaningful conversion - I think it is more for editing a pdf file
2. pdf2ps - ps2pdf seemed promising, but pdf2ps does not convert - it crashes with following error. Maybe there is a setting I am missing - I like this method because I can batch process all my pdf files with a simple script. If anyone knows what this error is please feel free to comment.
Error: /undefined in --filter--
Operand stack:
--dict:6/6(L)-- false false --dict:9/12(L)-- --nostringval-- --nostringval-- JPXDecode
Execution stack:
%interp_exit .runexec2 --nostringval-- --nostringval-- --nostringval-- 2 %stopped_push --nostringval-- --nostringval-- --nostringval-- false 1 %stopped_push 1 3 %oparray_pop 1 3 %oparray_pop --nostringval-- 2 1 501 --nostringval-- %for_pos_int_continue --nostringval-- --nostringval-- --nostringval-- --nostringval-- 1 %stopped_push --nostringval-- --nostringval-- %array_continue --nostringval-- false 1 %stopped_push --nostringval-- %loop_continue --nostringval-- 34132 --nostringval-- --nostringval-- --nostringval-- --nostringval-- --nostringval-- --nostringval-- %array_continue 7 11 %oparray_pop --nostringval-- --nostringval--
Dictionary stack:
--dict:1070/1417(ro)(G)-- --dict:0/20(G)-- --dict:73/200(L)-- --dict:73/200(L)-- --dict:97/127(ro)(G)-- --dict:229/230(ro)(G)-- --dict:19/24(L)-- --dict:4/6(L)-- --dict:22/31(L)-- --dict:1/1(ro)(G)-- --dict:7/15(L)--
Current allocation mode is local
ESP Ghostscript 7.07.1: Unrecoverable error, exit code 1
skoobwoman is offline   Reply With Quote