View Single Post
Old 01-11-2013, 03:28 AM   #121
Junior Member
Alexmark began at the beginning.
Posts: 2
Karma: 10
Join Date: Jan 2013
Device: Amazon Kindle App on Android Tablet
Thumbs up Thanks, but need help

Originally Posted by kovidgoyal View Post
Hi all,

After several weeks of fun getting all of calibre's dependencies to build on Windows 64bit, I finally have a working 64 bit build of calibre in Windows.

The installer is designed to install calibre 64bit alongside an existing calibre 32bit install. So you can switch between them until you figure out which one you want to use. The shortcut for launching calibre 64bit is named "calibre 64bit - E-book management" and when running it the status line at the bottom of the main calibre window will say [64bit].

The advantages of the 64 bit build are it can use all the RAM on machines with more than 3GB of RAM, which allows conversion of certain large and messy documents. There also may be small performance improvements.

The downside is that since this a new build there may well be some bugs that lead to crashes.

So if you are running a 64 bit version of Windows, try out the new calibre 64bit build and let me know how it goes.

Note that calibre has had 64 bit builds for linux and OS X for years.
Thanks for all help you are giving for all of us, and hope that you as a guru can help me as well.
I have an Android 4.0 tablet (Sophix) with a Kindle App installed on it. I want to transfer my downloaded ebooks through USB cable and got a problem from the very beginning. I can't make Calibre running on my Win7 64 bit Toshiba laptop.
I tried older versions (7.20, 7.38) and 9.13 64 bit as well. The installation is running smooth, but I can't launch Calibre. I tried all FAQs and HELPs. I uninstalled it 10 times, restarted, deleted the folder Calibre, Calibre2 in Program Files, in Programm Files x86. I deleted folder "caliber" in C:\User\AppData...I installed it in C:\library folder (if I got you right)....I've never found metadata.db file, that's why I didn't delete it....
And finally, after I spent hours, I ran debug, and asking for your assistance.
Help please,

Here is my debug log:

Python function terminated unexpectedly
(123, 'CreateFile', 'The filename, directory name, or volume label syntax is i
ncorrect.') (Error Code: 1)
Traceback (most recent call last):
File "", line 132, in main
File "", line 108, in run_entry_point
File "", line 50, in load_module
File "site-packages\calibre\", line 21, in <module>
File "", line 50, in load_module
File "site-packages\calibre\", line 65, in <module>
File "site-packages\calibre\utils\", line 94, in set_translator
File "site-packages\calibre\utils\", line 55, in get_lang
File "", line 50, in load_module
File "site-packages\calibre\utils\", line 440, in <module>
File "site-packages\calibre\utils\", line 352, in __setitem__
File "site-packages\calibre\utils\", line 366, in set
File "site-packages\calibre\utils\", line 298, in set
File "site-packages\calibre\utils\", line 113, in __enter__
File "site-packages\calibre\utils\", line 32, in __init__
pywintypes.error: (123, 'CreateFile', 'The filename, directory name, or volume l
abel syntax is incorrect.')
C:\library\\calibre\ RuntimeWarning: Parent module 'cal
ibre' not found while handling absolute import

The system cannot write to the specified device.

I fixed it. I had created an account in Windows in Cyrilic letters long time ago. I renamed it later, but the User name stays the same. That's why I had syntax error all the time. As a solution, I had created a new admin account with English letters and everything is running like a charm.

Thanks again.

Last edited by Alexmark; 01-31-2013 at 11:05 PM. Reason: Found the solution
Alexmark is offline   Reply With Quote