View Single Post
Old 01-06-2013, 09:43 AM   #1
Junior Member
kaistian began at the beginning.
Posts: 3
Karma: 10
Join Date: Jan 2013
Device: none
calibre-server: Doesn't server up newly added files

When I add new files to Calibre Library they show up on the web page with cover but is missing the "Get" button.
If I go to the the mobile version I get the link to the file and when I click it I get the following message:
404 Not Found
book: 338 does not have format: EPUB
Powered by CherryPy 3.2.2
Open the files I added a while back works on the web and all files open without problem in the client so it's just the web that is the problem.
$ pwd
/data/calibre_bibliotek/Linux Journal/Linux Journal January 2013 (338)

$ ls -1
Linux Journal January 2013 - Linux Journal.epub
I have also tried restarting the calibre-server but that did not help. And the server is started as root like this:
/usr/bin/python2.7 /usr/bin/calibre-server --auto-reload --with-library=/data/calibre_bibliotek --pidfile=/var/run/ --port=7777 --max-cover=300x400 --username=test --password=test --daemonize
The server_error_log.txt doesn't show any error messages.

From the server_access_log.txt
Code: - test [06/Jan/2013:14:58:34] "GET /get/EPUB/Linux Journal-Linux Journal January 2013_338.epub HTTP/1.1" 404 723 "" "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:17.0) Gecko/20100101 Firefox/17.0"
I have tried "Check library" but it shows no problems.

Some info:
Kubuntu 12.04 AMD64
Calibre 0.8.38 from Universe
Firefox 17 and Chrome 23

Anyone have some hints?
kaistian is offline   Reply With Quote