View Single Post
Old 01-04-2013, 04:22 PM   #1
Junior Member
kibbler1138 began at the beginning.
Posts: 5
Karma: 10
Join Date: Jan 2013
Device: Kindle Keyboard
K3 KB not fully refreshing, pixelated text, some inverted colors

I've yet to see any posts about a similar issue, everything I find relates to cracked screen substrates or "yes, you may want to hit Alt+G"...

My wife's 2yr old K3-Keyboard (3G) had the notorious "loose screw" issue. You could hear it rattling around, but it never seemed to cause problems. Just recently, I decided to cause a ton of problems and take care of it myself.

I turned the Kindle off (held power button just until the screen went blank), opened the case, and out popped 4 of the small black screws. I did not see where they were hiding, they just shook loose. Put them back together, and restarted the Kindle.

Booting up, it looks fine, even the main menu looks pretty good, but text within books looks as though there's no anti-aliasing - very pixelated, and images (lock screen, illustrations in books, hidden picture gallery thing) are inverted in some places and sort of overly contrasted in others.

I tried a bunch of stuff, removing screws again, checking for broken traces, etc. Wound up buying used K3 KB (wifi-only) off ebay. Swapped screens. No luck, same issue. I tried the original screen in the new Kindle - when I hotswapped them (Kindle was running, just swapped the display connector), the images looked normal on the old screen, but when I restart the Kindle (hold power off for 30 seconds, let go, wait for boot) with the old screen attached, the problem returns.

So - I have two Kindle Keyboards. I'll call them "G" (wife's original with 3G) and "W" (new one with just wifi)...

1) Running G with G's screen OR W's screen ---- problem
2) Running W with W's screen ----------------- all is good
3) Running W with G's screen ------------------ all is good until I restart

Here's a pic of the two kindles side by side. The original with the problem is on the left.

I've tried doing multiple restarts, swapping out all possible components, and doing a factory reset. No dice.

I figure there may be something wrong with both the image on the flash chip in the flexible display connector and the mainboard. The flash chip on the display connector (holds the waveform info) gets read on startup, so I assume that's why things get borked when running scenario #3 above.

I haven't seen anyone else complain about this. I'm hoping running through the de-bricking process may help (maybe the latest upgrade to 3.4 got corrupted somehow due to screws shorting something?), I'll start that tonight.

Hoping for any insight into other places to look. Called Kindle support, but they were no help. Sorry for the wall of text!

Last edited by kibbler1138; 01-04-2013 at 04:30 PM. Reason: Change image link to URL
kibbler1138 is offline   Reply With Quote