Thread: Content Server
View Single Post
Old 12-30-2012, 03:14 PM   #13
Junior Member
roadstar began at the beginning.
Posts: 9
Karma: 10
Join Date: Dec 2012
Device: Kobo
Originally Posted by DoctorOhh View Post
You have to worry about port forwarding on the router that the computer running the content server connects to.

If the IP you are using starts with 192.168.x.x, 172.x.x.x, 10.x.x.x or 127.x.x.x then you are using the wrong IP to try and connect with the content server from outside your local network. You need to use the external (internet facing) IP address of your WAN.

Try this thread for a better understanding.
Ok...after much adieu, it's working! (famous last words). Thanks for the link the other thread. Too many IP addresses!...speednet showed me one, my router showed me another and Calibre showed me another one (not cluing me into the fact that this is only local). However, this is the only IP address presented by Calibre as the way to access your library anywhere in the world. So this cryptic journey has not been a welcome one, eating up way too much time.
To continue...I tried every one of the IPs above and nothing worked. I forwarded the port, and when my router rebooted it showed yet another IP, which was like the one speedtest showed, but again it didn't work. I changed a port forwarding setting, rebooted, used the new IP and now it works!! I don't get why it didn't work when I forwarded the port...but who cares, it's working. So, a password has been safely applied, and working.
I think it would be a good idea to use a static IP, as was suggested.

To all, thanks for all the help and ideas, I hope others will benefit by this thread.
hew.... (Calibre, why didn't you just tell me in the first place)
roadstar is offline   Reply With Quote