Thread: K5 JBPatch
View Single Post
Old 12-30-2012, 02:19 PM   #981
orpheus2011 began at the beginning.
Posts: 25
Karma: 10
Join Date: Oct 2011
Device: Kindle
Originally Posted by DuckieTigger View Post
Thank you. First things first (and a big disappointment maybe). The file looks great in each and every font I tried. Compared to the english part of it every size I tried (I only tried the ones that are standard - without custom sizes or options out of JBPatch) they look about the same size. Some fonts change the arabic font of the text. If I use any of the 6 normal fonts of the PW however, then it defaults to the embedded font that is attached. Or my guess would be that it defaults to the default font that is installed on the PW - and assuming that the font you attached to the azw3 is simply lacking arabic characters. The first 2 images (pubsmall and publarge) are screenshots of the smallest size and the 2nd largest by default PW settings with the publisher font enabled (the one that is embedded). For comparison I attached a few more with different fonts - all on the same 2nd largest size) You can see, that on some the arabic font is displayed different. For simplicity I just going to name the picture after the font I used.

Very intersting things:
- Arial (the only one that says is designed for arabic, shows the exact same font that the embedded one does)
- Times New Roman - has no arabic as expected - defaults to standard arabic - this is the windows font though, not the one out of macos
- arabic typesetting shows very beautifully - but renders slow - not sure though if it is easier to read or not it is too bad that that font only comes in reguar - no italic or bold
- both tahoma and tektron pro show different style (that looks similar to the english) even though they are not supposed to support arabic

I really can't see what your problem is, all appears to be fine on my PW.
Many thanks for taking the time to do all these tests. Much appreciated. I am using all the latest firmware (5.3.1) and software versions. I get similar results, but basically am unable to get beyond 2 file sizes - the very small and very large ones. I will test further with the fonts you have used and let you know. The embedded font (B Lotus) is not being shown and is a fully Arabic/Persian compliant one. None of these screenshots shows the default font, which if I am not wrong is code2000, which has an entirely different typeface. As in my case, the font rendering is correct .
orpheus2011 is offline   Reply With Quote