View Single Post
Old 12-17-2012, 05:00 PM   #6
Junior Member
Struikrover began at the beginning.
Posts: 3
Karma: 10
Join Date: Dec 2012
Device: Nexus 7

Originally Posted by chaley View Post
Can't help with the permission problems, although I would guess that it is forcing the login because calibre is asking to talk to the screen while calibre-server does not.

As regards running the server standalone, the documentation you are looking for is here. The "missing books" probably happen because the instance of calibre-server is looking at the default (empty) library instead of the "real" one you have put somewhere else. You have two choices:

1) use the --with-library option to calibre-server
2) use the CALIBRE_CONFIG_DIRECTORY environment variable to tell the content server to use the same config that GUI calibre uses.

The first is almost certainly easier.

Hi guys,

Many thanks for the feedback. I had some more time with my setup and the calibre stand-alone content server. I checked the firewalls of both the Admin & Standard User accounts and both calibre64bit and calibre server are allowed through, so that shouldn't be the culprit. Chaley, I also tried your excellent first suggestion by adding an argument to the server instance, trying to point it to my library, which is indeed located somewhere else (on an external drive).

I wasn't entirely sure where to add the --with-library argument, so I added it under the scheduled task, first behind the actual program executable (like in the old DOS days), and secondly in the additional argument box. Unfortunately, neither will work and with the argument the task simply won't start complaining along the lines of syntax error. I tried the arguments both with "" and without, but not luck. I might not be adding it correctly?

Now get this, in the administrator account I can start the scheduled task (minus the above argument) for both the Admin and Standar User Account. However, connecting with CC to the running remote server under Admin account my library shows up as it should. If I run the exact same task but for my Standard User Account (followed by logging into that account) I can connect to the server but once again only the quickstart book shows up. That's so strange

So I suppose my next question is = what is the correct way of adding the library argument to my task? Even if it doesn't work, surely it shouldn't throw me a syntax error.....Would the problem be that my library is located on an external drive? I should add that the Standard User Account has read access only to my external drives...I configured it that way under account privileges. So I will try moving my library to the standard location. Does the stand-alone server keep a log I can have a look at, and where may I find it?

If all this fails I'll look into option 2, but I am open to anyone's suggestions

Many thanks for your time so far, =)
Struikrover is offline   Reply With Quote