View Single Post
Old 12-14-2012, 06:12 PM   #1
Junior Member
Struikrover began at the beginning.
Posts: 3
Karma: 10
Join Date: Dec 2012
Device: Nexus 7
Server and Account Permission Issues

Hi Guys,

I'm new here and been using calibre to serve my library to my device. Awesome piece of software I have to say =) but alas I have run into some 'technical' difficulties. Spent the last few days trolling all the forum for related post that may give me a hint but luck so far, so I figured I'll have to ask one of you calibre wizards with more expertise cause I'm fresh out of ideas...

What I would like to do
Serving my book library via the content server on a HTPC which is on 24/7, and I would like to use calibre companion to browse my HTPC library via Wifi on my Nexus 7. Sounds easy?

How far I got so far
I have a functioning (W7 Ultimate, 64Bit) HTPC which runs XBMC 24/7, with 2 accounts (one administrator & one Standard User Account). Basically when I press the power button it automatically logs into the standard user account and starts XBMC which feeds my TV (and can control with my tablet). Reason I have it in Standard User account is so programs don't inadvertently tamper with my media. That's what my admin account is for.

So I installed Calibre 64bit on this server and have it load my library on start-up. No problems so far. I created a scheduled task event (in admin mode) which starts the stand-alone calibre server on start-up (in standard user account). I checked that this task starts up under Standard User Account (with Scheduled Task library) and it indeed does so (task running). And my Nexus 7 appears to connect to this server but I don't see my book library (only the one calibre quick-start guide book)?

There do not appear to be any options I can play with on the server side and don't know how to run command-line instructions on the stand-alone server (can't find any manual instructions on it either, only the content server that is started within calibre is mentioned). I know the stand-alone server runs because when I start the content server within calibre it crashes (because it is doubling up, so the log says port 8080 is not available).

I have tried it the other alternative way around as well. Having Calibre start upon booting and starting the content server upon start-up. I can connect with my nexus to this server (automatic settings) without problems and the books show in CC. I can also connect to it as a device and send books to the Nexus. The problem with this method is that I always get prompted to provide admin password upon start-up, and I have literally tried every option, in vain, to make this prompt go away (assigning highest privileges in task scheduler, giving the Calibre icon to start in admin mode and putting that in the start-up folder. Nothing seems to make the prompt go away (it does its job in that regard very well =). I deduct this problem doesn't exist with the standalone server because it is read-only?

So I desperately need help from brighter minds here =). 1) Would it be possible to run the stand-alone server and fix this books-not-serving problem? Are there any prefs or command line instructions I can give it somehow? Alternatively if this route doesn't pan out, is there a way to run calibre upon start-up in Standard User Account without prompting? The one thing I would really rather steer clear off is disabling UAC, or giving this Account admin rights (by permanently changing its privileges).....=) Congrats if you made it this far...!

Struikrover is offline   Reply With Quote