View Single Post
Old 12-11-2012, 07:05 PM   #11
rononmaximus began at the beginning.
Posts: 10
Karma: 10
Join Date: Dec 2012
Device: Kobo Touch
Well, it didn't work I sent an email to Kobo support and they told me to try the same thing, factory reset.

I don't understand what's wrong and it's very annoying. Of course I can read the book not using the navigate icon and browse the library without thumbnails but those functions should be working.

I tried downloading the book again from the store and adding it to the device and no luck. Then I tried uploading a free ebook through ADE and that worked fine, displaying the cover and totally ok with using the navigate icon.

It can't be because my brother still has them on his device, right? If that was the problem, it wouldn't let me transfer them. Since it's a problem with reading and displaying covers, I assume it's a software issue?

My brother is already saying he'll never update his Kobo until I solve this...
rononmaximus is offline   Reply With Quote