View Single Post
Old 12-05-2012, 02:17 PM   #1
cbalmforth began at the beginning.
Posts: 14
Karma: 10
Join Date: May 2010
Device: Sony PRS-300, Kindle, Kindle Fire 2
Kindle Fire - Linux Mint problem SOLVED

I've spent 3 days trawling the internet and chasing red herrings trying to find an answer to my problem, now it's time to ask the experts!

I've been a happy Calibre and Kindle user for a couple of years now. Many thanks for a fine program! However I bought a Kindle Fire last weekend and I just can't get Calibre to recognise it at all. I am running Linux Mint 14 (just updated, the same problem happened on Mint 13). After installing mtp-tools I am able to transfer files to and from the device using gmtp but the OS doesn't recognise the device as either a drive or an MTP device and Calibre ignores it.

Here is the output from Calibre Debug device detection:
calibre 0.9.8  isfrozen: True
Linux-3.5.0-17-generic-x86_64-with-debian-wheezy-sid Linux
('Linux', '3.5.0-17-generic', '#28-Ubuntu SMP Tue Oct 9 19:31:23 UTC 2012')
Python 2.7.3
Linux: ('debian', 'wheezy/sid', '')
USB devices on system:
[['0x4a9', '0x220e', '0x100', u'Canon', u'CanoScan', u''],
 ['0x15d9', '0xa4d', '0x100', u'', u'USB OPTICAL MOUSE', u''],
  u'USB 2.0 Reader',
 ['0x1949', '0xa', '0x216', u'Amazon', u'Kindle', u'D026A0A02416142W']]
Looking for devices of type: MTP_DEVICE
No known MTP devices connected to system
Looking for devices...
Devices possibly connected: None
This line shows the device being seen on the usb port by Linux
['0x1949', '0xa', '0x216', u'Amazon', u'Kindle', u'D026A0A02416142W']]
but it doesn't seem to be recognised as an MTP device.

Can anybody help me please?

<EDIT> Extra information
My Kindle is a Kindle Fire 2 with 10.2.3 firmware

Last edited by cbalmforth; 12-07-2012 at 02:38 PM. Reason: Problem solved
cbalmforth is offline   Reply With Quote