View Single Post
Old 10-29-2012, 12:39 PM   #21
David28227 began at the beginning.
Posts: 12
Karma: 10
Join Date: Oct 2012
Device: Kindle Touch
Originally Posted by David28227 View Post
I'm pretty sure I did it exactly right, as per the instructions, but this happened

david@ubuntu:~$ cd /tmp; git clone
Cloning into 'imx_usb_loader'...
remote: Counting objects: 110, done.
remote: Compressing objects: 100% (55/55), done.
remote: Total 110 (delta 58), reused 105 (delta 53)
Receiving objects: 100% (110/110), 33.38 KiB, done.
Resolving deltas: 100% (58/58), done.
david@ubuntu:/tmp$ cd imx_usb_loader; make
cc -c imx_usb.c -o imx_usb.o -Wstrict-prototypes -Wno-trigraphs -pipe -ggdb `pkg-config --cflags libusb-1.0`
Package libusb-1.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `libusb-1.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'libusb-1.0' found
imx_usb.c:33:20: fatal error: libusb.h: No such file or directory
compilation terminated.
make: *** [imx_usb.o] Error 1
I tried deleting the /tmp/imx_usb_loader directory and doing it again, same result.
scratch that, figured out I needed libusb-dev. Installing and retrying
David28227 is offline   Reply With Quote