View Single Post
Old 10-16-2012, 06:08 AM   #1
Junior Member
Kek began at the beginning.
Posts: 9
Karma: 10
Join Date: Mar 2012
Device: Prs-650
[Calibre2OPDS] Some links are not working.

Hello all!
First thank you for this program. It worked really well with Dropbox, generating a truly functional catalog. Sadly I had (as many other users) to shut down the catalog and switch back to a personal FTP.

And now the problem:
The catalog is working flawlessly on my Local Computer...but the distant catalog present on the FTP is behaving strangely. All files are present, the catalog folder is an exact copy and I have some dead links. Not listed in the catalog, when I browse and get to the point where they should be listed, I have less entries.

Lets say I click on "All books". First page lists 20 books, second page lists 20 books, third page lists 15 books and forgets to show the Lovecraft ones (for example).
The lovecraft folder is there and if I manually check the FTP, the .epub files are there...but for a reason I don't know it's not listed by Calibre2OPDS.

I would say 95% of the links are ok, 4% are "forgotten", 1% gives links with errors ("the file is not present" error...even if it is on the FTP).
I built and uploaded the catalog multiple times without any change. Tried the 3.1 and 3.0 build without any changes too.

Maybe I do something wrong, maybe it's a known either case I searched and found if someone has a clue...I'm all ears

Thanks in advance.
Kek is offline   Reply With Quote