View Single Post
Old 10-09-2012, 04:13 PM   #1
CapnGoat began at the beginning.
CapnGoat's Avatar
Posts: 11
Karma: 10
Join Date: Oct 2012
Location: Canada
Device: Kindle Keyboard 3G (US)
Unable to update Kindle Keyboard to 3.4

Hello everyone,

Amazon released Kindle Software 3.4 today and I wanted to update my Kindle Keyboard 3G (US/B006). The update however failed with a U007 error.

I've been using Duokan on my Kindle for about a year and was very happy with its custom screensavers that didn't require a jailbreak but about half a year ago I became greedy I wanted to have those custom screensavers on my normal Kindle OS, too. I also read this interesting article on how to install Luigi Rizzo's standalone Kindle terminal and decided to give it a try.

I jailbroke my Kindle with the 0.10.N jailbreak. I installed the USBNetwork and then the ScreenSaver hack (I'm not sure what version any of those were at the time), the latter, I believe, failed but my greed wasn't big enough to figure out how to fix that, I was already nervous enough to jailbreak my Kindle in the first place.

A few weeks later I realized that the jailbreak had disabled my 3G card. I'm very dependent on the 3G functionality in my Kindle Keyboard and thus uninstalled the USBNetwork hack and the jailbreak. 3G worked again and I thought that was it.

And today, as I said in the beginning, Amazon released Kindle Software Update 3.4, which I tried to install but it failed with a U007 error.

I figured something must have not worked correctly with the jailbreak uninstall. I downloaded the 0.10.N jailbreak and tried to uninstall whatever was left on my Kindle. I got another U007 error. I tried to install the jailbreak but got a yet another U007 error.

I removed Duokan, made a factory reset on my Kindle and tried again and again. I also tried just restarting with the un/install .bin on my Kindle but just got an "Update Error: 3" message, which didn't bring me any closer to solving this problem.

I've been searching for a few hours now and all I could find were suggestions to reinstall the jailbreak (which I'm trying but it fails), making sure I install the correct jailbreak (k3g-3.2.1, still failing) and emptying the fonts folder (I never touched the fonts hack, therefore I don't have a fonts folder).

The "Update Error: 3" search brought me to a few tutorials on how to debrick a Kindle. My Kindle itself works perfectly fine, it's just unable to update its software. I wouldn't call that a bricked Kindle. Besides, restarting the Kindle with the un/install .bin on it was bound to fail, as I've read in other threads.

I'm stumped. Could anyone of you kind souls help me?
CapnGoat is offline   Reply With Quote