View Single Post
Old 10-08-2012, 02:24 AM   #1
Junior Member
anthonyliu began at the beginning.
Posts: 5
Karma: 10
Join Date: Oct 2012
Device: Kindle
Calibre won't start - KeyError: <type 'tuple'>

I was trying to customize a recipe but maybe did something wrong. I closed Calibre and now it won't open. I tried all the recommendations on Calibre's FAQs but none of those worked, so I ran the debug command line and here is what I got. Thank you so much for your time and all your help will be super appreciated!

C:\Users\Anthony Liu>calibre-debug -g
DEBUG: 0.0 KoboTouch:initialize
calibre 0.9.1
Windows-7-6.1.7601-SP1 Windows
('Windows', '7', '6.1.7601')
Python 2.7.3
Windows: ('7', '6.1.7601', 'SP1', 'Multiprocessor Free')
Starting up...
Traceback (most recent call last):
File "site-packages\calibre\gui2\", line 266, in initialize
File "site-packages\calibre\gui2\", line 247, in initialize_db
File "site-packages\calibre\gui2\", line 223, in initialize_db_stage2
File "site-packages\calibre\gui2\", line 175, in start_gui
File "site-packages\calibre\gui2\", line 210, in initialize
File "site-packages\calibre\gui2\", line 270, in __init__
File "site-packages\calibre\gui2\actions\", line 30, in init_sche
File "site-packages\calibre\gui2\dialogs\", line 438, in __init__
File "site-packages\calibre\web\feeds\recipes\", line 149, in __init__

File "site-packages\calibre\web\feeds\recipes\", line 184, in do_refre
File "site-packages\calibre\web\feeds\recipes\", line 113, in get
File "site-packages\calibre\web\feeds\recipes\", line 71, in seri
File "site-packages\calibre\web\feeds\recipes\", line 57, in seri
File "site-packages\lxml\", line 222, in __call__
File "site-packages\lxml\", line 197, in add_dict
KeyError: <type 'tuple'>
anthonyliu is offline   Reply With Quote