View Single Post
Old 10-07-2012, 09:38 PM   #11
Dog Dentist
tarvoke began at the beginning.
tarvoke's Avatar
Posts: 108
Karma: 18
Join Date: Sep 2011
Device: PE, GT540, VM670, GOGHVMU, Qualcomm 1600
Originally Posted by mickael28 View Post
I tried to reinstall the system but I don't know how. I tried:

1- going to 'system->privacy->factory data reset'
2- downloading the + for the Allmine version and rebooting with them.

But after the update the system was exactly in the same status, nothing had changed.
I seem to recall that using the built in "reset" can have some very bad effects (may be misremembering here tho, thinking of my phone) - and in any case I think all it would do, if it works, is erase user data but not really affect the system.

reinstall should take care of any bad blocks, and take care of any possible corrupted files.

golden allmine is definitely my preferred way to reinstall (see ). you'll find plenty of opinions and anecdotes here on this forum, whether to use usb flash drive or SD for reinstall. one thing most people seem to agree on is, whatever flash memory you end up using, don't have anything else on it except (and if you like), and to use as small a flash as you have (I've had pretty consistent good luck with a 4gb HP usb)

you "should" be able to clean up the filesystem just as normally in linux, but remember that here the volumes actually live on top of UBIFS (so, loop-mounted fat32 image file on top of EXT on top of ubi on top of raw flash - actually I think there is still one more layer at the bottom there?) on a device that suffers weird spontaneous corruption and/or bad blocks if you look at it wrong. i.e. the corruption may not even be in the intsdcard image, it may be in the system volume, screwing up system binaries so that intsdcard appears unavailable or dirty (but may be neither - frostschutz' helpful explanations notwithstanding, your fsck binary or mount binary itself could be bad!)

so, people do have varying experiences with how corruption of system flash memory affects behavior - it is possible for it to be mild enough for the device to be usable, although who can say how long it would remain stable. some of the times it happened to me it was somewhat usable at first but became progressively worse - eink side stopped working, eventually boot-loop every time I turned it on. the most recent time it took me a whole bunch of tries to get a reinstall to work, and at one point I became seriously afraid the reinstall would never work (whew! lucky!)

for other brave souls on this forum (hi vicinc!), some physical hacking and serial reprogramming was required. ouch.

in the past I never had problems at all, it was only this year for 2 reasons:
- letting the battery die while unplugged and turned on (EDIT: oh - or, letting the battery die while hibernating /EDIT)
- trying to run latest kindle app (also just about any version of google books app)

man, we really need to get all this kind of stuff in a wiki.
tarvoke is offline   Reply With Quote