View Single Post
Old 09-29-2012, 08:48 AM   #7
Junior Member
KernelDev0815 began at the beginning.
Posts: 1
Karma: 10
Join Date: Sep 2012
Device: PRS T1
Got a blank, "dead"(?) device? Not so fast, there might be some clues remaining!
At least it might still be possible to get it to do USB storage transfer.

I've got a PRS-T1 with what seems to be display problems (stays blank whatever I do).
No reset efforts whatsoever helped (restricted to those suitable for firmly staying in non-rooted / non-recovery areas...).
PRS-T1 "Data Transfer Mode" still worked, though:
I wrote a nice little shell script (Linux) to immediately detect a newly registered device:

# cat /usr/local/sbin/

while :; do
for suff in b c d b1 b2 c1 c2 d1 d2; do
dd if=/dev/sd${suff} of=/dev/null count=1 2>/dev/null && echo "sd${suff} OK" || echo -n '-'
sleep 0.03

(make sure to adapt the list of devices to not include any PC-side ones)

Then I tried hitting the "Data Transfer Mode" acknowledge button that's supposed to appear on the display once connected to PC. Guess what - it worked, it did specifically connect USB storage right after managing to hit the correct area on the *blank* screen (see e.g. and "help with getting books onto PRS T1" for images that show the Data Transfer Mode button display location).

Removing existing content of the internal storage did not help to make it work *in my case*, however. IOW, for me unfortunately it's an almost-DOA RMA case (wow, acronym party! . Oh well...
KernelDev0815 is offline   Reply With Quote