View Single Post
Old 09-23-2012, 05:58 AM   #3
Junior Member
josefec began at the beginning.
Posts: 1
Karma: 10
Join Date: Sep 2012
Device: PocketBook 622 Touch
Unhappy Not charging when plugged to PC


I think I’ve got a problem with charging my PocketBook Touch. When I connect it to PC and select to enter battery charging mode, it shows a “spark” symbol in the battery icon but the LED is not blinking. I’ve had it connected for hours and the battery icon is still empty when I disconnect the device from the computer. Also when I look into advanced setting in my Windows 7 system, it does not show the device and no USB controller shows any energy consumption, that means that no electricity enters the device. I tried multiple USBs on my PC, it did not help. I also tried to reset (click the reset button) the device when connected and reset it and then connect, again nothing. The version of the firmware on the device is D622.3.2.122 which is newer than the latest on the website, which is D622.3.2.108.

Is there any way how to solve this or what should I do? I’m going to try some wall USB charger if nothing helps but I thought that I will get along only with the USB cable and my PC. I haven’t found anyone mentioning this problem anywhere in the deep waters of Internet.

Thanks for any advice or help.

Last edited by josefec; 09-23-2012 at 06:01 AM.
josefec is offline   Reply With Quote