View Single Post
Old 09-06-2012, 10:17 AM   #9
Junior Member
rkh5 began at the beginning.
Posts: 7
Karma: 10
Join Date: Sep 2012
Device: Kindle
Hitch: Yes, these are two separate issues. One is that the .mobi isn't recognizing the table of contents. In response I create the .prc, which solved the Table problem but then wouldn't display the characters. If I can solve one of these problems, I can ignore the other.

I almost solved the ToC problem, but not entirely. In Previewer, I can see both the html Table (which is not in a separate file but is contained in the same html file as the full text) and the ncx table from the relevant buttons at the top of previewer. The problem is that it doesn't appear on my actual device. I should say that on my device I can actually flip to the table manually, it just isn't linked from the menu. The chapter divisions via the ncx work fine, I can use the 5-way to flip between chapters on the device.

As far as I can tell I think the table is properly marked. I've got a bookmark in the html file and a reference to it in the opf. And indeed it is working in previewer, just not on the device. And I've tried on two separate devices, a regular Kindle 3.3 and an iPad Kindle app, both with the same results.

I know little to nothing about character encoding, so I'll have to look up to see how these characters are being treated. But I was careful to only use characters that actually appeared on my device. But I was only checking by converting html to mobi via previewer, not via mobipocket and a prc file. My limited research makes it seem like the prc simply doesn't support the characters I want, but mobi clearly does, so ideally I'd like to try to fix the table in mobi without a prc, rather than addressing the characters.

Last edited by rkh5; 09-06-2012 at 10:20 AM.
rkh5 is offline   Reply With Quote