View Single Post
Old 08-25-2012, 02:31 AM   #1
Junior Member
Nepherius began at the beginning.
Posts: 1
Karma: 10
Join Date: Aug 2012
Device: kindle keyboard 3g
Calibre can't convert anything anymore

Calibre seems to be unable to convert anything anymore. It's a problem that started for me a few weeks ago with version 8.62 and that keeps occurring no matter what newer or older version I install.

Every time I try to install a version, I get this error message: "There is a problem with this Windows Installer package. A DLL required for this install to complete could not be run. Contact your support personnel or package vendor."

I'm wondering how I could fix this problem since installing // reinstalling doesn't do the trick.

I've attached a screenshot of my error message, a bug report the program made after I tried to convert an epud file to mobi, and the original epub ebook. I've specifically tried to convert an ebook that calibre already successfully converted in the past, so I'm sure the problem isn't the ebook itself.

Also, here is the error log I get when I tried to convert the file.

calibre, version 0.8.66 (win32, isfrozen: True)
Conversion Error: Failed: Convert book 1 of 1 (Enders Game 1 - Ender's Game)

Convert book 1 of 1 (Enders Game 1 - Ender's Game)
Resolved conversion options
calibre version: 0.8.66
{'asciiize': False,
'author_sort': None,
'authors': None,
'base_font_size': 0.0,
'book_producer': None,
'change_justification': u'original',
'chapter': u"//*[((name()='h1' or name()='h2') and re:test(., '\\s*((chapter|book|section|part)\\s+)|((prolog|pr ologue|epilogue)(\\s+|$))', 'i')) or @class = 'chapter']",
'chapter_mark': u'pagebreak',
'comments': None,
'cover': u'C:\\Users\\Neph\\AppData\\Local\\Temp\\calibre_0 .8.66_tmp_mgkxvb\\yndjfg.jpeg',
'debug_pipeline': None,
'dehyphenate': True,
'delete_blank_paragraphs': True,
'disable_font_rescaling': False,
'dont_compress': False,
'duplicate_links_in_toc': False,
'enable_heuristics': True,
'extra_css': None,
'extract_to': None,
'filter_css': u'',
'fix_indents': True,
'font_size_mapping': None,
'format_scene_breaks': True,
'html_unwrap_factor': 0.4,
'input_encoding': None,
'input_profile': <calibre.customize.profiles.InputProfile object at 0x041FE690>,
'insert_blank_line': True,
'insert_blank_line_size': 0.5,
'insert_metadata': False,
'isbn': None,
'italicize_common_cases': True,
'keep_ligatures': False,
'language': None,
'level1_toc': None,
'level2_toc': None,
'level3_toc': None,
'line_height': 0.0,
'linearize_tables': False,
'margin_bottom': 5.0,
'margin_left': 5.0,
'margin_right': 5.0,
'margin_top': 5.0,
'markup_chapter_headings': True,
'max_toc_links': 50,
'minimum_line_height': 120.0,
'mobi_file_type': u'old',
'mobi_ignore_margins': False,
'mobi_keep_original_images': False,
'mobi_toc_at_start': False,
'no_chapters_in_toc': False,
'no_inline_navbars': True,
'no_inline_toc': False,
'output_profile': <calibre.customize.profiles.KindleOutput object at 0x041FE9D0>,
'page_breaks_before': u"//*[name()='h1' or name()='h2']",
'personal_doc': u'[PDOC]',
'prefer_author_sort': False,
'prefer_metadata_cover': False,
'pretty_print': False,
'pubdate': None,
'publisher': None,
'rating': None,
'read_metadata_from_opf': u'C:\\Users\\Neph\\AppData\\Local\\Temp\\calibre_0 .8.66_tmp_mgkxvb\\y9jv91.opf',
'remove_fake_margins': True,
'remove_first_image': False,
'remove_paragraph_spacing': True,
'remove_paragraph_spacing_indent_size': 1.5,
'renumber_headings': True,
'replace_scene_breaks': u'',
'search_replace': '[]',
'series': None,
'series_index': None,
'share_not_sync': False,
'smarten_punctuation': False,
'sr1_replace': None,
'sr1_search': None,
'sr2_replace': None,
'sr2_search': None,
'sr3_replace': None,
'sr3_search': None,
'tags': None,
'timestamp': None,
'title': None,
'title_sort': None,
'toc_filter': None,
'toc_threshold': 6,
'toc_title': None,
'unsmarten_punctuation': False,
'unwrap_lines': True,
'use_auto_toc': True,
'verbose': 2}
InputFormatPlugin: EPUB Input running
on C:\Users\Neph\AppData\Local\Temp\calibre_0.8.66_tm p_mgkxvb\dykysk.epub
Python function terminated unexpectedly
[Error 5] Access is denied: u'C:\\Users\\Neph\\AppData\\Local\\Temp\\calibre_0 .8.66_tmp_mgkxvb\\nszvlc_plumber' (Error Code: 1)
Traceback (most recent call last):
File "", line 132, in main
File "", line 109, in run_entry_point
File "site-packages\calibre\utils\ipc\", line 192, in main
File "site-packages\calibre\gui2\convert\", line 31, in gui_convert_override
File "site-packages\calibre\gui2\convert\", line 25, in gui_convert
File "site-packages\calibre\ebooks\conversion\", line 979, in run
File "site-packages\calibre\customize\", line 234, in __call__
File "site-packages\calibre\", line 436, in __enter__
WindowsError: [Error 5] Access is denied: u'C:\\Users\\Neph\\AppData\\Local\\Temp\\calibre_0 .8.66_tmp_mgkxvb\\nszvlc_plumber'

If anyone could help me, it would be much appreciated.
Moderator Notice
Removed copyrighted attachment..
Attached Thumbnails
Click image for larger version

Name:	Calibre install.png
Views:	192
Size:	90.1 KB
ID:	91263  
Attached Files
File Type: txt tmplp1iqm.txt (8.1 KB, 96 views)

Last edited by theducks; 08-25-2012 at 06:46 AM. Reason: Remove copywrited attachment
Nepherius is offline   Reply With Quote