View Single Post
Old 08-19-2012, 05:36 AM   #3
Steven630 began at the beginning.
Posts: 147
Karma: 10
Join Date: May 2012
Device: Kindle Paperwhite2
Originally Posted by cryzed View Post
This error is usually thrown when you try to open a relative URL without having opened the absolute URL beforehand, i.e. you try to access "wiredscience/2012/06/mf_icons_diamandis/all/" without beforehand having opened the actual site "". More code would be useful.

Also, regarding your update: You didn't actually post the error, just a small part of the TraceBack.
Sorry for my late reply. But I don't think it's a problem about relative URL.

Because in the log I saw:

Failed to download article... from
Traceback (most recent call last):
File "site-packages\calibre\utils\", line 95, in run
File "site-packages\calibre\web\feeds\", line 1007, in fetch_article
File "site-packages\calibre\web\feeds\", line 1002, in _fetch_article
Exception: Could not fetch article. The debug traceback is available earlier in this log

The link is complete.

Just now, the same error poped up when I tried to download using another recipe that has worked well so far. Strangely enough, although all articles are arranged in the same way, only some articles experienced this. (say, there are articles, ABCDE, all are in complete links and are identical apart from their contents, the recipe always failed to download ACD)

Traceback (most recent call last):
File "site-packages\calibre\web\fetch\", line 462, in process_links
File "site-packages\calibre\web\fetch\", line 240, in fetch_url
File "site-packages\mechanize-0.2.4-py2.7.egg\mechanize\", line 199, in open_novisit
File "site-packages\mechanize-0.2.4-py2.7.egg\mechanize\", line 216, in _mech_open
BrowserStateError: can't fetch relative reference: not viewing any document

Last edited by Steven630; 08-19-2012 at 05:42 AM.
Steven630 is offline   Reply With Quote