View Single Post
Old 08-01-2012, 07:33 AM   #4
Junior Member
Fernblatt began at the beginning.
Posts: 5
Karma: 10
Join Date: Jun 2012
Device: All
Question Did that...

Originally Posted by SameerH View Post

Try this for the desktop app:

1. Download an app called 'Appcleaner' for mac here: and install it.

2. Start the appcleaner app.

3. open your Applications folder, and drag the kobo icon to the appcleaner window.

4. Appcleaner will prompt you to delete all associated files, go ahead and do this.

5. Go to and download a fresh version of the application and install it.

This should fix your problem.
SameerH ---

I am having the same problem with my iMac. I used both AppZapper and AppCleaner, even went into terminal and used the grep command to find any loose bits or pieces on my system. After that I manually went through every folder to see if there were any bits hiding, but found none. Tried rebooting after every uninstall. Emptied the trash after every uninstall. FSCK'd the drive, looking for anything odd or out of place in the way of corrupt or fragmented files, drive and data are intact. I let the software automatically download and update, that didn't work. I downloaded the software from the Kobo site, that didn't work either.

No joy. I still get the dialog window that pops up telling me I need to update the reader software, which I do. And each and every time, at least for the past 8 hours or so, the new installation prompts me AGAIN to update.

My hardware is late 2010 27"iMac, 1 Tb hdd, 16 Gb RAM

Fernblatt is offline   Reply With Quote