Thread: PRS-T1 Enormous battery drain
View Single Post
Old 07-13-2012, 06:25 AM   #1
RhialtoFalu will become famous soon enoughRhialtoFalu will become famous soon enoughRhialtoFalu will become famous soon enoughRhialtoFalu will become famous soon enoughRhialtoFalu will become famous soon enoughRhialtoFalu will become famous soon enough
Posts: 21
Karma: 548
Join Date: Oct 2011
Location: The Netherlands
Device: PRS-T1
Enormous battery drain [pastlog, pastlog_thread, past_wake_lock, FIXED]

First, the context:

About a week ago something weird happened with my T1. It had been rooted with Porkupan's sets. I have never installed any firmware updates so it was still the version.
I was just turning a page in CoolReader when I got stuck in a reboot loop. A few seconds the rotating arrows, then a blank screen for a few seconds, and repeating.
After a forced reset with a paperclip, the T1 restarted a bit better, but many programs "accidentally terminated": at least BarTab, Keyboard, ADW Launcher... but the original Sony programs seemed to be still working.
I have been reading books in this situation for a day or 2.

Since this appeared to be more or less a software problem (although it was worrying that this started so suddenly) I thought to do a restore and firmware update. I started out with the official Sony firmware update to 1.0.04 updater, but it didn't want to do anything. (No "updating" appeared on the screen and the firmware version wasn't changed).
So, I tried a SD rescue set of Rupor to go to 1.00.04 that way. That also wasn't a 100% success; it was supposed to take 20 minutes but after a few hours I gave up and I reset. It turned out it had reverted to an apparently clean and unrooted version of 1.00.00.
Ok, so I tried the Sony updater again and this time it worked, giving me a clean 1.00.04.
As I understand it, this update replaces ALL firmware, the kernel, ramdisk, the recovery environment and the Android environment, right? So whatever had been corrupted would have been replaced by now.
After that I installed Rupor's AMR and his pack to enable ADB/Apps2SD.
All this seemed to work fine. I re-installed CoolReader.

However, and now we get to the problem:

the battery lasts barely more than overnight now! Even when the reader is in sleep mode, after a few hours more than overnight, it shuts down. The last thing it does is put up a warning screen that the battery has low power, and that it is disabling the network (which wasn't enabled in the first place).

Would this be a software problem (some software that keeps running and eating power), or some hardware problem after all? If I try to get a warranty repair/replacement it would be annoying if it was some software issue which I could have fixed myself.

Looking at the software angle, here are the first few lines from the output of top in the adb shell.
This "pastlog_thread" seems to be running all the time, and 23% system CPU time seems rather high... the reader was supposed to be idle at the time apart from running top and adb over usb.

User 0%, System 23%, IOW 0%, IRQ 0%
User 2 + Nice 0 + Sys 74 + Idle 234 + IOW 0 + IRQ 0 + SIRQ 0 = 310

  PID CPU% S  #THR     VSS     RSS PCY UID      Name
 1110  13% D     1      0K      0K  fg root     pastlog_thread
  310   8% S     1      0K      0K  fg root     esdhc_wq/0
 2626   3% R     1    948K    388K  fg root     top
 2137   0% S    47 278676K  41256K  fg system   system_server
    5   0% S     1      0K      0K  fg root     khelper
    8   0% S     1      0K      0K  fg root     async/mgr
    9   0% S     1      0K      0K  fg root     pm
   12   0% S     1      0K      0K  fg root     suspend
   76   0% S     1      0K      0K unk root     usb_wakeup thre
Edit: I also tried the battery recalibration by removing the file /data/system/batterystats.bin. It made no difference.

Last edited by RhialtoFalu; 07-22-2012 at 06:36 PM. Reason: update title
RhialtoFalu is offline   Reply With Quote