View Single Post
Old 07-07-2012, 06:10 PM   #57
kraqh3d began at the beginning.
Posts: 20
Karma: 10
Join Date: Jan 2012
Device: Kindle
Hmmm... It's not working for me.

I'm running WinXP in Virtualbox. WinXP can see the usb device for the Kindle (as seen in my syslog)

usb 1-7: new high-speed USB device number 28 using ehci_hcd
usb 1-7: New USB device found, idVendor=15a2, idProduct=0030
usb 1-7: New USB device strings: Mfr=1, Product=2, SerialNumber=0
usb 1-7: Product: SE Blank RINGO
usb 1-7: Manufacturer: Freescale SemiConductor Inc

I configure ATK based on the previous screen shots. The loading RAM kernel bar completes. ATK flashes "Waiting for USB Connection...". I'm not sure why. ATK won't even let you continue past the first configuration screen if it doesn't see it on USB. And I definitely see the device in the device manager.

What happens next is the Kindle resets its connection on the USB bus, and then ATK gives me this error: "Failed to initial flash or Do not support this Flash, please reset the target".

I've tried both dump and program. And its always the same error. For giggles, I tried holding down the Vol- knowing that its going to reset, but that didnt help either.

I see two possible things... The mmc might be totally fubar'ed. Or I still don't have enough juice because if I let it sit here, it'll keep reseting on its own about every 90 seconds. With nothing else to loose, I'm off charge it some more.

** edit **
I decided to try with my working kindle. I dumped the first 8MB. It too bounced when ATK connected to it. I ran the dump through getkernels, and successfully diff'ed the output main_kernel.img against the main_kernel.img produced from the dd of the first 32MB from mmc I had earlier. So I know the software works. I hope its a power thing.

Last edited by kraqh3d; 07-07-2012 at 07:59 PM.
kraqh3d is offline   Reply With Quote