Thread: Pixelar MReader
View Single Post
Old 06-24-2012, 04:14 PM   #1
Junior Member
DG1966 began at the beginning.
Posts: 1
Karma: 10
Join Date: Jun 2012
Device: none
Pixelar MReader

Hello, wonder if anyone can help.

I have a Pixelar Mreader S6-5W.

I put some mobi books on it and disconnected it from the computer. I admit I could have not disconnected right, but I read the instructions twice and thought I had.

On turning on, the reader goes through the load up process, then just says that there is a SD card error suggests restart then just stops. Generally on a page with lines on and just does nothing. I have to reset to restart and it goes through the same process. I tried two different SD cards and even left the SD card out, no effect.

I tried updating the software from the web page. Theres two there for download , and I've downloaded and tried them both. They load up perfectly, going through the update process exactly as described on the web page, but then it just grinds to the same old halt again. Each time declaring card error regardless of whether theres a card in or not.

It doesn''t respond to the usb cable been plugged in or offer usb tranfer or charge and doesn't respond when the wall charger is plugged in.

I was just wondering if anyone had any ideas, is there for instance a different firmware to try? Or is there a combination of buttons to try?

If you've got this far on this post. Thanks.
DG1966 is offline   Reply With Quote