View Single Post
Old 06-13-2012, 06:57 AM   #1
Mayr began at the beginning.
Mayr's Avatar
Posts: 65
Karma: 16
Join Date: Sep 2009
Location: Porto, Portugal
Device: Sony PRS-505, iPhone 3Gs
Kindle Touch sort by recent doesn't work

My Kindle touch stoped organizing books by most recent.
I tried restarting the kindle and it stayed the same.
I then made a factory reset and it didn't fixed it either.
I deleted all my collections and did another factory reset.
Turned on the wifi, registered the kindle and purchased some new free books from amazon to test (didn't connect the kindle to calibre or transferred any books this way), but it still doesn't organize my books by most recent.
I set the clock manually to the correct time in my country and tuned on the wifi since I read it automatically sets the correct time, altough it doesn't seem to do so when i purposely set the wrong time manually.

My Kindle touch currently has the 5.1.0 firmware.
I have run out of ideas to fix the problem. Any help?


Last edited by Mayr; 06-13-2012 at 07:04 AM.
Mayr is offline