View Single Post
Old 05-29-2012, 06:28 AM   #11
Junior Member
Cordula began at the beginning.
Posts: 8
Karma: 10
Join Date: May 2012
Device: PRS-T1
I spent quite a few hours with my device and all I achieved was running in circles. I am grateful for any idea about what could be the problem or what could be done. I think my device is not bricked but rather crooked.

Points where I'm stuck:
- I cannot use rupor's root. Whenever I flash it, my reader will freeze in the Opening book screen on every startup, requiring an sd recovery
- with Boroda's root I cannot move apps to sd in spite of using enable-asec.
- some apps (amazon, mantano) won't install and/or run as they are supposed to
- the sd revovery behaves kind of strange, sometimes working, sometimes not (my success rate is much higher when using the "" as compared to uboot's ""). When it does not work, the orange LED at the power button is flashing, but the sd card-LED is not, I am quite sure that means that nothing is happening.
- Moreover after revovery, it never reboots. The mission accomplished sign is that the black opening book bar turns white, making a reset via reset button necessary.

Possible Causes
1) There is a slight chance my firmware was not 1.04 when I first rooted. When I look at the device info now, it says 1.04 and I cannot install sony's firmware because it says the firmware is up to date.
2) Something went terribly wrong when I flashed enable-adb. The main symptom (no longer mounting drives) could be repaired by sd-rescue, but maybe something is still damaged.

For the very patient, an approximate list of my activities in my as of yet inconclusive attempt to brick my device
1. Boug a PRS T1
2. flash rupor's AMR
3. flash rupor's enable-asec
4. messed up by adding a google-account, which lead to apps closing down. I thought before I do a recovery, I try the other stuff, so:
5. Tried to install some apps, parts of which worked. Some apps would not install, although the wiki says the opposite (e.g. amazon kindle app).
6. flashed enable-adb, then something went really wrong:
7. FIRST BIG PROBLEM: The reader did not mount/recognize any SD-card ("internal" or external) anymore, I couldn't mount them with my notebook via usb.
8. I tried sd-card rescue for a couple of times until it worked. SD-cards were mounted again
9. I did factory initialization
10. I wondered that adb would still pop up (thanks for explaining this)
11. I tried flashing rupor-amr again. NEXT PROBLEM: Whenever I flash with rupor-amr, the reader will not get past the "opening book"-screen. The black bar will fill up and then nothing happens OR the black bar will fill up, freeze for 10 s and then the reader reboots. All I can do at that stage is sd card recovery
12. I flashed both rupor-disable-all and disable-adb
13. I flashed boroda's minimal and it worked okay
14. I tried installing some apps. Some would work (google mail), some would not (amazon)
15. I flashed rupor-enable-asec over boroda's minimal, but moving apps to sd still would not work.
16. After freeing 28 MB I could install mantano reader (my main goal), but it only started once and then never again.
17. I flashed boroda's removal package
18-99. I moved in circles for quite a few times with rooting, recovering, swearing and so on, but I always get stuck at the points named on top.
57. At one point I tried installing the sony firmware. Because the sony installer didn't do anything by itself, I tried it according to the "update your firmware in linux" howto and copied the unzipped update-package onto the READER-partition. But when I tried rebooting in recovery mode, the black bar instantly turned white again and there was no apparant effect.
Cordula is offline   Reply With Quote