View Single Post
Old 05-27-2012, 06:54 PM   #7
Junior Member
jb0nez began at the beginning.
Posts: 7
Karma: 10
Join Date: May 2012
Device: Kindle Fire
Ok I've tried your settings. Note that I'm converting mobi to mobi, not epub to mobi, so I don't know if that makes a difference. I'm also adding a cover image. That's actually the entire point of this exercise, I want my books to have covers not blue/white generic icons.

So I removed all instances of the file from my calibre library and from my kindle, re-added the original mobi, downloaded a cover only (no other metadata), set my options identically to yours, converted mobi to mobi (with your identical settings), copied the file over USB in the Documents folder, rebooted my kindle just to be safe, and...nothing. Doesn't show up Books or Documents.

I've also tried a conversion to azw3 and no luck either.

Like I said, the very first time I tried this mobi to mobi conversion, it worked fine, it just had the generic cover. Since then NOTHING will show up. I can email myself the file to and get a prc out of it that shows up and is readable no problem, but then it has the generic icon.

I'm going to attach the mobi file I am using. It's not copyrighted, it's public domain from the Guttenberg project. Do you mind trying and letting me know if it works for you? If so then it's something on my kindle -- which is quite possible, it's rooted so not stock and that may add some variables.

Edit: I converted the mobi file to epub using Calibre, then opened it in Kindle Viewer. Kindle Viewer converted it to mobi but with warnings (though when I looked through the log I couldn't see any warnings). So I took THAT mobi file (which was twice as big as the Calibre version of it) and copied it to my kindle;s Books directory over USB and rebooted. Doesn't show up. I emailed myself the epub version of the file (which has a cover in its metadata) to and it converted it and delivered it to my kindle -- without the cover!! AGH!

Edit2: Something is just wrong with my kindle. The "New Oxford American Dictionary" that we get for free is listed in my books as in my library but not downloaded. I hit download and nothing happens. So I went into to my library, hit download and install over USB, took the 23MB AZW file and put it into Documents as Amazon says to do and it doesn't show up! (Though my emailed and converted mobi file does).
Attached Files
File Type: mobi (4.16 MB, 140 views)

Last edited by jb0nez; 05-27-2012 at 07:35 PM.
jb0nez is offline   Reply With Quote