Thread: Tools CoolReader 3 on Kindle
View Single Post
Old 04-25-2012, 08:26 PM   #121
Junior Member
tstngry began at the beginning.
Posts: 6
Karma: 10
Join Date: Apr 2012
Device: Kindle Keyboard 3g
Before I ask my question I would like it to be known I worked very hard on this problem, searched the board, and google, and was still unable to resolve my issue.

I have a Kindle Keyboard 3g with the following installed and working:
screensaver hack:

I attempted to install CoolReader3 from both the links supplied in post #1. I did the keyboard shortcut Shift + C + R, and nothing happend... So next I sshed into my Kindle and tried to launch it from there or see if it was one of the running processes (which it wasn't). When I tried to launch it manually I recieve the following error:

[root@kindle cr3]# ./cr3
./cr3: error while loading shared libraries: cannot open shared object file: No such file or directory

I checked to make sure that file ( was present and it was, I even tried copying it into the directory right next to the cr3 executable, but to no avail. If anyone has any tips or suggestions or has expirience with this problem I would greatly appreciate any advice. Thank you.

Of course right after I make this post I figured out the problem, although I find it strange that nothing was mentioned in the installation instructions. I copied the files from /cr3/lib/ to /qtkindle/lib/. Maybe someone should update the installation instructions for people who might encounter the same problem.

Last edited by tstngry; 04-25-2012 at 09:10 PM. Reason: Solved Problem
tstngry is offline   Reply With Quote