View Single Post
Old 06-22-2008, 01:43 AM   #12
Indigo Ink
The curious one!
Indigo Ink began at the beginning.
Indigo Ink's Avatar
Posts: 82
Karma: 10
Join Date: Apr 2008
Location: India
Device: Kindle 3, Nook, Ebookman 901
Originally Posted by Nate the great View Post
I'm sorry to hear that.

I do have one last suggestion. There is something I want you to try. Use Notepad or Wordpad to open one of the nonfunctional ebooks. Search for BOOKMOBI , and replace it with TEXtREAd . Then save the ebook. Tansfer it to your ebookman and see if it works.

This may or may not work. If it does, then you have a simple way to hack the ebooks so they work. If not, then you will need to look into the Mobipocket tools around here. You'll need to disassemble the file to it's HTML, then put it back together.
First of all, thanks for the suggestion Nate. However, it seems it would not work. After I made the suggested changes, the book refused to open up on mobipocket reader (I tried it only on the pc version).
However, I did the next best thing. I downloaded the 4.8 version of mobipocket on ebookman, (if I remember correctly I had that version on my ebookman earlier too but during some upgrade/downgrade process it seems I inadvertently downloaded the 4.4 version). So with the 4.8 I opened 'David Belfour' and voila! it opened! (well, Nate had already pointed out that it would open but nevertheless voila!.) I tried the dictionary next and that opened too!! What joy!! Meanwhile I am keeping my fingers crossed that mobipocket 4.8 does not crash my ebookman OS.

Thanks a lot everyone and especially Nate the great!!

Last edited by Indigo Ink; 06-22-2008 at 01:52 AM.
Indigo Ink is offline   Reply With Quote