View Single Post
Old 03-19-2012, 03:29 AM   #20
Junior Member
ChrissyB began at the beginning.
Posts: 1
Karma: 10
Join Date: Mar 2012
Device: Kobo Touch
Unhappy Trying to setup my Kobo Touch

I am trying without success to setup my Kobo Touch. I've downloaded the Kobo software - no problem. When I connect it to my PC, the eReader shows "Connected and Charged" but I cant get past the first screen of the Kobo setup, which tells me to plug in the eReader.

My PC is telling me that the drive needs to be formatted, and I'm not sure what to do.

I've borrowed a friends cable, in case that was the issue - no luck. I've un-installed the Kobo software and re-installed - no luck. I've re-booted the computer - still no luck! I've always used the eject process when disconnecting the eReader. I've also tried other USB ports.... my last option is to try my friends laptop, in case it is a computer issue.

Has anyone else had this issue, or have any other advice? Please note I am pretty tech-useless!
ChrissyB is offline   Reply With Quote