View Single Post
Old 03-04-2012, 12:12 AM   #38
john_pb began at the beginning.
Posts: 26
Karma: 10
Join Date: Feb 2012
Device: Kindle Touch
Guys, thank you all very much, and particularly to you Geekmaster, for taking so much time to work out these repair techniques and to help the likes of me, whose technical knowledge would never be at the required level.

Yes, it is easy and relatively cheap to just buy a new Kindle, but you are correct that there's no fun in that, and one definitely will not learn anything that way.

Now to my Kindle again:

SSH is still working, so I have tried as a first instance to run the /usr/sbin/factory_reset script. Here's the result:

[root@[192_168_15_244] sbin]# ./factory_reset
./factory_reset: source: line 3: can't open '/etc/upstart/shutdown_modes'
So that's why trying to do it via a did not work.

Next I tried to mount /mnt/us to see if the system image file could be accessed that way. Bingo - it worked!

From there, I was able to run the dd command, seemingly without problems:

[root@[192_168_15_244] us]# dd if=/mnt/us/mmcblk0p1.img of=/dev/mmcblk0p1 bs=4K
89600+0 records in
89600+0 records out
367001600 bytes (350.0MB) copied, 201.749597 seconds, 1.7MB/s
I have to say I struggle a bit with the ash shell in BusyBox (if that's what it is) as being used to zsh, the minimal verbose output and lack of autocompletion makes it a lot more difficult for non-professionals like me.

Anyway, with the above completed, it seems I'm still not out of the woods yet. I'm not getting the "Your Kindle needs repair" screen any more, but the device is stuck on the tree logo and won't boot from there.

Going back into diags and trying once again to run the factory_reset command via SSH gives the same error as before.

This is a pretty stubborn brick considering it was all caused by a simple firmware update...
john_pb is offline   Reply With Quote