View Single Post
Old 02-27-2012, 08:31 AM   #92
Junior Member
TommyLau began at the beginning.
Posts: 5
Karma: 10
Join Date: Feb 2012
Device: Kindle Touch
Originally Posted by geekmaster View Post
When a kindle in fastboot mode is plugged into your host PC USB port, you should see a USB device with VID/PID 0x1949/0xd0d0, indicating that the kindle is in fastboot mode.

You can also get the kindle fastboot tool and type (for the linux version):

sudo ./fastboot getvar bootmode

and it will show "<waiting for device>" until it sees a kindle in fastboot mode. When it sees one, it will run the command (getvar bootmode in this example) and exit.

Please do not use fastboot to erase or flash partitions on the kindle yet. The touch fastboot module seems to write to the wrong area, according to serial port status messages. There are other ways to do this that are more reliable at this time.
Thanks for your reply, I've removed the back cover and try to use the battery in Kindle on my Sprint Epic 4G with wired line, and it successfully turned on the Epic 4G and the phone shows its about 30% of the battery left, even I used the battery from Epic 4G, still no luck in getting into either diag mode nor fastboot mode. Any ideas?

PS. Both Kindle Touch's battery and Epic 4G's battery are 3.7V Lion battery, only difference is Kindle's is 1420mAh, Epic 4G's 1650mAh.

I can enter the HID(USB Recovery Mode), and if I tried to download the fastboot profile, it download six times, and it notice that download sucessfully, and then the lasting time is continue counting, the button still shows "Abort".
TommyLau is offline   Reply With Quote