View Single Post
Old 02-23-2012, 05:39 PM   #1
Junior Member
mzecher began at the beginning.
Posts: 9
Karma: 10
Join Date: Feb 2012
Device: iRiver Story HD
"Updating your Story HD... Please wait" loop

First of all, sorry if asked before. I really couldn't find a solution for this.

I own an iRiver Story HD since about 3 months, currently running latests firmware (1.29) updated through OTA.

The problem is as follows: I put any SD card, the device recognizes it and displays "Updating your Story HD... Please wait". This message disappears after a few seconds and then jumps in again in an endless loop. If I pull out the SD card, the device gets responsive again. It happens no matter they are empty or filled with files. The same happens if I put the card with the device off.

I tried with 3 different sized cards:
- Transcend 32GB SDHC Class 10
- Patriot 32GB SDHC Class 10
- Sandisk 2GB SD (don't know which class)

I also tried formatting every card a few times. The same happens with firmware version 1.25, 1.21 and 1.19.

If I remove the "system" folder from Story HD, it reads the card fine until the next time it has to update the database, at which time it goes into the loop again. So, basically I have to remove the system folder each time I plug the device into computer, each time I insert a card and each time I turn the device on (at least it doesn't happen when waking it up from suspend state).

I already wrote at iRiver's customer service a month ago and was told to reformat, to try previous firmwares, and finally to wait to a new firmware version (1.29, which didn't solve anything), but actually got no real solution (still waiting for a new answer). So I decided to ask here, since I think mobileread users know more about this device than the people working at iRiver.

Thanks in advance for the attention and any clue.
mzecher is offline   Reply With Quote