Thread: perl for kindle
View Single Post
Old 02-16-2012, 10:19 PM   #9
sjheiss began at the beginning.
Posts: 58
Karma: 26
Join Date: Dec 2011
Device: K3G, KF2
OK, I've installed bozohttpd on my K3G with no errors, can load a page with localhost, using the command line bozohttpd -b -c /mnt/us/www/cgi-bin -X /mnt/us/www, but when I try to submit a form, it says that it can't download the file, which I'm assuming means that either CGI didn't initiate or I'm incorrectly using the Perl I installed, and it's trying to download the .cgi file rather than load it.

I don't really know much about bozohttpd, nor am I sure what to put in the shebang line of index.cgi, so the problem might lie there.

I've attached the files I'm using for this Perl program, which works with no problems on my computer.

I have tried both


As I have correctly made a symlink as per this thread, but neither way changed anything. I'd be very happy if someone could help me.

F.Y.I. I was successfully able to print out "hello world" in the tutorial by fbdev, so I am sure that Perl is correctly installed.

UPDATE: I tried going to http://localhost/cgi-bin and it says the Kindle can't load the page, even though the cgi-bin shows up in the directory if I go to localhost with no index.html, so I don't know what's going on...
Attached Files
File Type: zip Perl (703 Bytes, 249 views)

Last edited by sjheiss; 02-16-2012 at 10:33 PM.
sjheiss is offline   Reply With Quote