View Single Post
Old 01-30-2012, 04:12 AM   #1
Nalapombu began at the beginning.
Posts: 20
Karma: 10
Join Date: Jan 2012
Device: Kindle FIRE
IRRITATING Problem with FIRE and MOBI files..


I got Calibre on the recommendation of a lot of Kindle users. I have the new FIRE.

I had not put any books on it yet and got a free book auto sent to me by Amazon, it came through with no problems.

On a tip I went and found some free books at, I downloaded the MOBI files as I was told these were the standard Kindle files that it recognized.

About 3 hours ago I loaded my 2 free MOBI books into Calibre and got set to transfer them via USB. I went through and corrected the covers and some of the metadata and was all set. I connected it, it recognized the device was plugged in and I started transferring. I thought I was home free as it was easy as can be.

I disconnect my Fire and look in my BOOKS section where my free Amazon book is, but no more books. Then I look in my DOCS section and they are there, no covers and not hardly readable. Jumbled characters, unable to zoom in on micro text, and so on. Well I thought I had done something wrong. I deleted the books from the DOCUMENTS section and tried again only to get the same results. I tried this procedure maybe 10 times all with the same result. No cover, no readable book and landing in the DOCUMENTS section.

Well I brought up the USERS GUIDE and followed it to the letter and still got the same results.

After maybe 15 times trying to get my MOBI books to land into the BOOKS section, I gave up. There is no way this is supposed to work like this. One thing is certain, if this can't be fixed, one or both of these technologies is getting removed from my universe and I'll save for an IPAD2.

Any help before I delete Calibre?

Nalapombu is offline   Reply With Quote