View Single Post
Old 12-13-2011, 08:35 PM   #1
Junior Member
GMCDiesel began at the beginning.
Posts: 2
Karma: 10
Join Date: Dec 2011
Device: Boox M90
Onyx Boox M90 Touchscreen Doesn't Work At All

Howdy all, I purchased a factory refurbished M90 (not an M91S) from eBay from the seller that I suppose to be the Onyx US dealer (if the device wasn't in fact factory refurbished, of course, this thread would be of a lot less interest I imagine) who has plenty of positive feedback (here is the auction:

The ereader arrived yesterday in acceptable cosmetic condition. After charging it for an hour, I turned it on (and had to reset it because it hanged at the boot screen, as I hear occasionally happens). After it booted, I could navigate with the 5-way IR sensor, but the device doesn't recognize the included white stylus at all. I tried tapping all over the screen and pressing fairly forcefully. I tried soft resets, clearing flash memory in settings, turning off and on; I also was able to launch the screen calibration application, but it didn't recognize the stylus at all, no matter where I tapped. I contacted the eBay seller this morning and have received no response; I will call them tomorrow.

I haven't heard of any problems of this nature (although I have heard of small dead areas directly above the speaker). If y'all have any input, I'd surely appreciate it.
GMCDiesel is offline   Reply With Quote