View Single Post
Old 10-15-2011, 04:07 PM   #39
Junior Member
force began at the beginning.
Posts: 3
Karma: 10
Join Date: Jun 2011
Device: Kindle 3 3G B00A
Originally Posted by metoo999 View Post
I don't know what's different. I had Yifanlu's jailbreak, screensaver hack, launchpad and probably some other things. I tried uninstalling the hacks, formatting to factory default, but no go. I double-checked that I downloaded the right 3.3 file for my Kindle 3 Wifi.

It's no big deal as the new features don't mean much to me, but it is annoying that I can't upgrade my firmware.

My firmware is 3.1 (558700031). I thought maybe it was because I had installed the provider hack months ago, so I tried uninstalling that, but no go (I'm not even sure if I had uninstalled in months ago after the 3.1 jailbreak came out).
Same was here aswell (same firmware), but now its went through.
I did a factory reset, than installed jailbreak, screensaver hack, launchpad, usbnetwork and at last the update_kindle_3.3_B00A.bin.
If still no go, than
1. backup your rootfs: dd if=/dev/mmcblk0p1 of=/mnt/us/mmcblk0p1.img
2. under Linux mount: sudo mount ./mmcblk0p1.img /mnt -o loop
3. search the incorrect files: sudo md5deep -o f -nM rootfs_md5_list.txt -r /mnt >> failed_hash_list.txt
4. replace the listed files with the original ones
Good luck
Attached Files
File Type: txt rootfs_md5_list.txt (172.0 KB, 367 views)
force is offline   Reply With Quote