View Single Post
Old 10-05-2011, 11:24 AM   #6
anthonyb began at the beginning.
Posts: 16
Karma: 24
Join Date: Sep 2011
Device: Kindle 3 WiFi v3.2.1
I've seen several posts asking where to get the USB Network driver (RNDIS) for Windows. However when I installed usbNetwork on my Kindle 3 WiFi I did so from a PC with Windows 7 Ultimate x64 SP1. After copying over the usbNetwork installer and completing the s/w update I toggled usbNetwork, plugged the USB cable back in, and my PC started to search the internet for a suitable driver. It took a good minute but eventually Windows automatically downloaded and installed the correct driver all on its own without me having to do anything!

Once the driver was installed I did have to go to Device Manager to manually set the IP address for the new device to Note that I've installed Microsoft's SUA (Subsystem for Unix-based Applications AMD64) on my PC so I simply started a Bash shell on Windows (installed seperately) and successfully ran ssh root@ to connect to my Kindle. It worked perfectly first time.

When I subsequently installed and started Luigi's KiTerm via scp and ssh, $TERM was still set to 'Interix' (from having connected from Windows) and commands like top would not run. After rebooting the Kindle everything worked correctly.

Last edited by anthonyb; 10-05-2011 at 11:40 AM.
anthonyb is offline   Reply With Quote