View Single Post
Old 09-21-2011, 07:14 AM   #5
Junior Member
smintman began at the beginning.
Posts: 5
Karma: 10
Join Date: Sep 2011
Device: Kindle3
Originally Posted by aruangra View Post

Good to hear that it works.

1. To make the debian 6.0.0 package, we must specify "squeeze" instead of "lenny"
debootstrap --foreign --arch armel squeeze chroottarget ""
Am I correct?

2. I am interested to know how you compile the source. Could you please elaborate more?
For example...What is the command for compiling ? What dependencies do you need to install before compiling? and How?

3. Does Calibre in your 211j work for both fetching news and serving contents as a webserver ?

I have several ARM-based PCs lying around. So, it would be useful if I can run calibre on it.

It was my first attempt with linux . Sorry, I don't know difference between lenny and squeeze. I used lenny, I changed only parameter --arch to armel, I thought it was mistake on that page. I have no problem with it.

With compiling it was bigger problem . Maybe becouse I did it for a first time. I tried to use your procedure, but in step 5 I was lost. I tried binary images, but they didn't work. Somewhere I found answer from kovid that there is no binary of calibre for ARM, so you must compile it.
So I tried procedure Source install from
1. One problem was with python, i didn't have version 2.7.1.
I followed instructions on page I added "deb unstable main contrib non-free" to #/etc/apt/sources.list and installed python2.7.
2. I thought, that I have all dependencies, so I continued.
wget -O- | tar xvz
Sources was downloaded.
4. I entered
python2.7 install
maybe 20 times. There was always some kind of error message that i googled and tried to solve. Most of them was missing dependencies. so I installed missing packages. I used frequently page, where I found missing package. I installed package with
apt-get install xxxxxxx
until it ends with no error. It ended with creating of calibre commands in /usr/bin/ directory.
5. Everything was compiled, I had calibre commands and I thought that I finished, but it didn't work when I tried to start calibre server. Error was "no such file python2:" And answer from google:
ln -s /usr/bin/python2.7 /usr/bin/python2

Ad 3.
I tried to fetch news as test.
ebook-convert /opt/calibre/recipes/dilbert.recipe /opt/calibre/serve/ --output-profile kindle
It works and create also nice same new kindle periodical as windows version of calibre.
After it I tried to add it to server and start.
calibredb add --duplicates --with-library /opt/calibre/serve/ /opt/calibre/serve/
calibre-server --with-library /opt/calibre/serve/ --port 8081 daemonize
And it worked. I downloaded ebook from browser http://diskstation:8081 and opened it in KindleForPC.
Scheduling and mailing is also working, there is only one little problem, that in scheduling system there is UTC time, that is probably from debian setup.

So it was hard for me, because I had no experience with linux,debian,arm till this week, I didn't understand most of things that I did and some steps may be obsolete or funny for linux geeks. But big my thanks goes to google and kovid for calibre. So if it can be done easier, let me know.
Today I will try to setup scheduler, based on your step 7.

Last edited by smintman; 09-23-2011 at 04:09 AM.
smintman is offline   Reply With Quote