View Single Post
Old 09-09-2011, 05:13 AM   #340
Junior Member
shikuru began at the beginning.
Posts: 3
Karma: 10
Join Date: Jul 2011
Device: Kindle DX Graphite
I just want to write a quick follow up on my problems updating my Kindle DX graphite. It turns out the Updates Provider patch had done some damage of my Kindle, that the uninstall script did not fix.
Originally Posted by shikuru View Post
From the log:
system: E _otaupexec:def:signature verification failed on "09/update-09-495460008-550650009.bin"
Namely, the updates-provider patch had left a hack-certificate on the device that its uninstall script did not remove. So I installed usbNetwork, SSHed into the device and deleted the certificate. After that, I could update from 2.5.7 to 2.5.8.

On 2.5.8 I had to jailbreak again. The newest version of it that was released recently for 3.2.1 and is supposed to work on all Kindles did NOT work on this DX. I used the 0.7-N instead which worked just fine. From then on, everything was a breeze. The prepare-update script worked fine after the jailbreak, and the 3.2.1 update installed just fine. I do have the 20-30 seconds wake-up issue, but that isn't too bad for me. The page flips seem way faster.

All in all, many thanks to yifanlu for the great work!!!
shikuru is offline   Reply With Quote